⚠️ Important notice: We regularly receive support tickets of people looking to change their password for a different NEXT. Please verify that you're a nextapp.co user (AI customer intelligence platform and customer insights) and are not looking to change your password for another NEXT website, such as next.co.uk!
Background
NEXT AI uses passwordless authentication — a secure login method that lets users access their accounts without a traditional password. Instead, identity is verified through factors such as email-based magic links, one-time codes, or hardware tokens.
Issue
During sign-up or subsequent access, you may experience a delay in receiving your magic link via email (e.g., around 30 minutes). Such delays may result in you experiencing invalid magic links as magic links are only valid fo 15 minutes.
Cause
NEXT AI sends magic links within seconds of your request. In most cases, delays are caused by corporate email security scanners (e.g., Proofpoint) operated by your IT department.
Verification
Step 1: Is the issue caused by a corporate email address?
If you can log in to NEXT AI: First, check whether your corporate email is the cause. Change your email address in NEXT AI to a public address such as @gmail.com. Request a new magic link — the email with the magic link should arrive in your Gmail inbox within seconds.
If you can’t log in to NEXT AI: Ask one of your NEXT AI administrators to change your account email to a non-corporate address.
Step 2: Does the corporate email scanner delay the emails?
Next, determine whether your corporate email scanner is causing the delay. Set your email address in NEXT AI back to your corporate address. Then open the internet message headers of the delayed email sent to your corporate inbox (see how-to guides for Gmail and Outlook).
Check the timestamps in the headers. In the example below, there is a ~36-minute delay attributable to email scanning (NEXT AI sent the email at 08:50 GMT; the email scanner finished processing at 09:26 GMT):
Received: from pps.reinject (m0062140.ppops.net [127.0.0.1]) by pps.reinject
(2.16.0.36/2.16.0.36) with SMTP id 00C2QAHD004213 for
me@example.com; Fri, 10 Jan 2020 09:26:10 GMT
Received: from a48-108.smtp-out.amazonses.com (a48-108.smtp-out.amazonses.com
[54.240.48.108]) by -00121503.pphosted.com with ESMTP id 4xbejs2c24-3
(version=TLSv1.2 cipher=ECDHE-RSA-AES128-SHA256 bits=128 verify=NO) for
me@example.com; Fri, 10 Jan 2020 08:50:27 +0000
Resolution
Contact your IT department and ask them to investigate why the email security scan is taking so long. Reach out to NEXT Support if we can provide your IT team with any additional information.
